During Scan - Walking through opened glass door not happening

I tried several ways to get this to work and had to leave. I have to go back and finish the rest of the model. This is very strange. The door was propped open the entire time. I moved the camera around the area trying to make it possible to get through the door. It's a wall of glass and a glass door. I marked them as mirrors, marked them as windows, removed the marks but can't get to the other side.

It was a very finicky scan for sure. You can see the scan locations in the bottom photo. I could only go as far as the scan in the doorway. I tried moving close and far to try and grab different areas. What ideas do you guys have for me?




  • @Jim felder

    So, you say 1. You couldn't scan there or 2. You did and cannot access the scans?

    1. I would think you marked before you scanned and the capture app thought it was a wall or you marked the door. I have done this before and then decided to go outside.

    2. I would walk through in mesh mode and see if you have any artifacts hanging in doorway. If so, I would use the trim tool and try to remove it.

    I wouldn't mark anything until after the scan is finished in that area. I would only mark as windows and leave a spot for the door. You could mark both sides but I don't think that is needed. If you need an example, I have a video of what icall the trim tool trick.

  • I could not scan further into the adjacent room. It would only let me Scan up to and inside the doorway. Thanks for the response. I’ll take a look at the mesh.

  • Did you have it marked with a window or mirror before you tried scanning?

  • Another trick is not mark the window and scan pin the other side of window and connect it back to door. The only reasons I cam think of marking windows is so you cannot walk through and to prevent spray.

  • I didn’t mark them as windows at first but as I was trying different things I did at some point mark them as windows. I also marked them on both sides. I mark them as mirrors. Because it was kind of dark in there and it was very reflective. I guess the best thing would be to delete those scans and start over. Should I just leave them as is and not try to mark them at all or should I mark them as windows? I didn’t put anything in front of the doorway being open.

  • I wouldn't mark them at all because it looks like it is inside building somewhere. Sometimes it is just trial and error!

  • Hey JustinV: Can you explain this again? I'm not understanding. Sorry.

    "Another trick "is not mark the window and scan pin the other side of window and connect it back to door. The only reasons I cam think of marking windows is so you cannot walk through and to prevent spray.

  • Sorry autocorrect on phone!

    In the picture you walk down hall on one side of window. Try to scan on other side of window and not going through the door at first. Scan area then come out the door.

  • Aaaahaaa! OK, I see. Here is a video of the Mesh. I'll try your idea. If not, I'll delete the current scans in that area and try again.



  • There is mesh there? If so, make sure all mirrors are marked. Let me find my video for trim tool.

  • support.matterport.com/hc/en-us/community/posts/115007177807-What-kind-of-video-tutorials-would-you-like-to-see-

    Scroll down and fast forward to about 7:30.

  • Hi @Jim Felder  Always a bummer when this stuff happens. When going back, I'd first try deleting the scan points in the doorway, and the one in the opening to the door.  Mark the open door door as a mirror, with the mirror on the side of the door facing the opening.  This should fix the problem. 

    Per @justinv, don't mark the windows and you can actually scan the hall on the other side of the windows.  But if you don't mark the open door as a mirror, you'll still get reflective artifact/scatter.

    I'm sure Justin is right that when looking within Mesh mode you'll see the dreaded hanging artifacts. 


  • Hi @Jim Felder,

    Can you please advise the name of the model so that I can take a further look into this please?

    I will move this into a support ticket to assist you further with this navigation issue your experiencing in this model.





  • The model is "Crystal Bridge Tropical Conservatory". 

  • Tiffany, I received an email that you posted a long message but it's no longer here. I have not been able to go back and scan again yet.

    Good advice here and in your message. The scan in the doorway was added after trying several other scans to try to get into the adjacent room that you see through the door. So I might delete those scans in that walkway and start over unless you think I should just leave them and scan some other locations to try and build on it.

  • Hi Jim,

    I sent you an email in the support ticket I created for you. I'll resend it to you so that you'll have it for reference. If you have any questions about what I advised just reply to the support ticket and it'll come directly to me.


    Its not necessary to start all over. When you return to rescan that area delete the two previous scans in the hallway leading up to the door, this is done so that the camera can pick up the scan trail and align properly. Try what I advised and let me know if that works.






  • Hello again,  it’s been since October 1 that I last uploaded this scam. I went back night before last to continue and try these different tips that were suggested. I was still unsuccessful.  At this point I tried to scan some other areas and continue up some stairways and I’m having issues with that. I’m going to post a separate question on these forms for a new issue. 

Please sign in to leave a comment.