Answered

Matterport models encountering WebGL error in browser

This happens in firefox and chrome, in South Africa. Both have been reinstalled and updated. I was just wandering if this is somthing that anyone eles is experiancing.

0

Comments

9 comments
  • Hi @jason-4,

    I'm just wondering if you're referring to 3D Showcase or Workshop? I imagine if anything is having issues with WebGL it would be Workshop, but just wanted to make sure.

    0
    Comment actions Permalink
  • Thanks for the reply Amir,

    I'm referring to the actual embedded link on the client's website. Once the model has loaded the browser pops up and error notification and the view area goes blank. Works on internet explorer however.

    0
    Comment actions Permalink
  • You could try to disable (or enable if it's currently disabled) hardware acceleration in your browser. Search for your specific browser's hardware acceleration setting change process.

    0
    Comment actions Permalink
  • Tried that Chris, and there is no more error popup. But the actual matterport model now says "opps encountered and error" with a black background. It doesn't seem to be happening on all PCs, as it works fine on everyone else in the offices chrome, its just my PC and a clients. Perhaps this is just a isolated occurrence, but will keep an eye on it.

    0
    Comment actions Permalink
  • If this is a public space, can you share the link?

    If you have not already done so, you should undo the hardware acceleration setting change I recommended.

    Another thing you can try is confirming that Javascript is enabled on the browser. It probably is, but it can't hurt to check. I believe Firefox doesn't allow you to disable it, but I think Chrome still allows you to turn it on and off.

    0
    Comment actions Permalink
  • If IE is working, they may want to make sure they're running the latest version of Chrome or Firefox to see if that's the problem. If that's still not working, I would contact the support department for a little deeper digging.

    0
    Comment actions Permalink
  • I have some Screens to share.

    The first thing I did, before posting this question, was to reinstall the newest Chrome and check for updates. It is on Version 56.0.2924.87 (64-bit) and up to date.

    Our site is apex3d.squarespace and it happens with all the models.

    This is loading it normally with hardware acceleration on.

    Moments after the loading is complete without any movements of the model the WebGL error occurs.

    This is the result with the hardware acceleration off, not WebGL error but after loading just shows this error mssage.

    0
    Comment actions Permalink
  • Thanks for posting this information. Your site looks great, by the way!

    Do you have this same error with other 3D technology (like a 360 view on Facebook - example: https://www.facebook.com/thegrandtour/videos/569107113287834/)?

    • Browse to chrome://flags
      • Verify WebGL Draft Extensions is disabled (You'll see an "Enable" link under this flag)
      • Verify WebGL 2.0 is set to "Default"
    • You can also try to flip these settings, relaunch your browser, and see what effect it has on viewing the model.
      • Click the Enable link under WebGL Draft Extensions, relaunch your browser, and try to view the model
      • If that doesn't work, leave WebGL Draft Extensions enabled, and change WebGL 2.0 to Enable, relaunch your browser, and try to view the model
      • If that doesn't work, leave WebGL Draft Extensions enabled, and change WebGL 2.0 to Disable, relaunch your browser, and try to view the model
      • If none of these works, disable WebGL Draft Extensions and try both Enable and Disable for WebGL 2.0
      • If you aren't successful, ensure WebGL Draft Extensions is disabled and WebGL 2.0 is set to Default
    • The issue could be related to a faulty installation in Chrome (it's not likely because you also report the issue for Firefox). Uninstall Chrome, then reinstall it. I've found that installing software on top of existing software will often NOT resolve issues - you need to remove the original files.
    • Finally, download and install the most current video drivers for your machine
    • If none of this works, or you aren't comfortable with what I suggest, please do contact Matterport Support - they are quite helpful!
    0
    Comment actions Permalink
  • I would reset all your Chrome://flags to their default settings and try again. Let me know how that works out. I'm also running Chrome 56 and not seeing the same issues when loading the Space. I went to your site and was able to load it there just fine. Let me know anything else you can about the computer you're using to access the Space.

    - Amir

    0
    Comment actions Permalink

Please sign in to leave a comment.