Answered

Scan showing up on the wrong floor

Odd one. I have a model where one of my scans shows up on a different floor. In my case I scanned a dining room with 4 scans around a table. The capture app has all 4 scans on floor "2" but workshop has one of the 4 scans on floor "1". I wound up just hiding the scan position as it was in a non-critical tour position. I could not re-upload my model as there were no changes (the problem scan was already on the correct floor). Any way to correct this in workshop?

0

Comments

24 comments
  • Just guessing, is there a mirror or window not marked correctly? That is usually why that happens.

    Is it right inside a doorway?

    Just make a copy on capture app and upload it again. Just Mark a wall with window our mirror and it will let you do it. Hopefully that will take care of it.

    0
    Comment actions Permalink
  • Although this can't be fixed in Workshop, if you don't mind providing the Space link, I'm more than happy to take a look at it.

    Also, to re-upload model data that hasn't changed, you can trick Capture by making any minor change such as tweaking any marking in the slightest or even adding a marking off to the side and then immediately removing it :)

    - Matterport-Amir

    0
    Comment actions Permalink
  • Yes, @justincolbyvaughn, it was the scan closest to a window. Per you and @Matterport-Amir's suggestion, I moved the marking for the window one tiny pixel and re-uploaded. The new model is now correct.

    I did zoom in as tight as I could in the capture app and noticed the scan in question is in a "shadow" of the nadir where I could not get coverage from another adjacent scan. Maybe that had something to do with it? Either way, it works now.

    Thank for your help!

    0
    Comment actions Permalink
  • I am glad it worked itself out for you.

    When you know there should be a scan spot and it isn't, it isn't a full circle or ends up in a wrong place, then it is usually something marked or not marked. A few times I have to use trim tool placed toward each other but I can usually get it working with a little hunting for issue.

    I do outdoor scanning when it looks good, so I see more problems dealing with going on and out.

    0
    Comment actions Permalink
  • I have this same problem with one scan point. In capture app the scan point 114 is placed in floor 3. But in showcase it is located in floor 2. I have duplicated the model in my iPad and uploaded it again making a few changes, but the problem persists. In fact, in workshop, that scan point appears in the 2nd floor list and I cannot move it. What can I do? I have to develop this model to my client and I do not know how to solve this. Help appreciated!

    0
    Comment actions Permalink
  • img-0756.pngimg-0754.pngimg-0755.pnghere are the pictures of that problem

    0
    Comment actions Permalink
  • @josepino

    Does the model work without that scan?

    Matterport might be able to move it but not until next week.

    Without seeing the model, I am totally guessing but I would think something isn't marked properly. Maybe a window or mirror. Make sure you over mark windows and mirrors.

    Worst case is make a copy in capture app and try to delete it and upload it again. That is only if you don't need that scan.

    Another option is delete that scan and go back to property and do that one scan again.

    0
    Comment actions Permalink
  • Thank you @justincolbyvaughn. Yes, the model works perfect but that special point is situated in the second floor instead of the third. Why it will be possible next week. Will then be a new version of workshop or so?

    You can see the model here.

    I think everything is properly marked and no mirror or window is missing. If you can see something wrong in it, please let me know. I have tried to make a copy of the model and upload it again but the problem persists.

    I have given the link to my client with the &f=0 extension so he cannot select the floor, but I need to correct that soon.

    0
    Comment actions Permalink
  • @josepino

    Model looks good. The only thing I can see is maybe the skylights.

    I couldn't find the scan walking through model but I saw it on the doll house. On the duplicated model, have you tried to delete it and reupload the model. Would that get rid of the scan showing on floor 2? Just make sure to make a copy and use it, so you have the original scan.

    I said next week because the Matterport team doesn't work weekends to fix things like this.

    Maybe @Matterport-Amir can take a look from behind the scenes and see if he can figure out what went wrong.

    0
    Comment actions Permalink
  • @@justincolbyvaughn

    Thank you again. I'm going to try that and I will let you know what's the result of that change.

    In the mean time, may be Amir can tell more about this kind of problem and how to solve it..

    What if I change the skylights of the ceiling and instead of window I mark them trimming from inside to outside? Just thinking out loud...

    0
    Comment actions Permalink
  • @josepino

    Just make a copy first and give it a try. It couldn't hurt!

    0
    Comment actions Permalink
  • Well , didn't work. Any other suggestions?

    0
    Comment actions Permalink
  • I would fill out a support ticket. Hopefully they will get to it pretty quick.

    0
    Comment actions Permalink
  • Hi @JosePino,

    This may sound strange, but regardless of how you set up the floors in Capture, once the model data is uploaded and processed, the floors are recalculated and all the scan positions are placed on a floor based on those calculations and predefined rules.

    My guess, in this case, is because the 3D depth data that scan position sees is not consistent with the rest of the 3rd floor - floor, it's just associating that scan position with the second floor. Meaning, because of all the things piled up in that corner of the room, the processing engine can't see the actual floor, or enough of it, in order to recognize it as the same floor.

    You could go to Capture, as @justincolbyvaughn, suggested. First make a duplicate of the model data and then delete that scan position from the duplicate and re-upload.

    The other option is to simply hide all the floors from 3D Showcase using the &f=0 parameter. Nothing changes in your Space, but visitors won't see the Floors menu and, therefore, won't be able to isolate the 2nd or 3rd floors to see this issue.

    I hope that helps.

    - Amir

    0
    Comment actions Permalink
  • Thanks @Matterport-Amir.

    I have already done what @justincolbyvaughn suggested and the problem persists.

    I cannot understand why if I mark a scan point in one specific floor, the system associates it to another floor. This shouldn't happen because it offers less capabilities to the operator to administrate the model. We should be able to decide where is that specific point situated in the space, in fact, I can associate each point to the floor I decide but the result after processing is always the same. I think that function of the system doesn't work properly. No one but the operator knows what is the correct distribution of the space that is scanned. This should be corrected by the Matterport Team.

    In the other hand, I have applied the f=0 parameter to this model, but my client may ask me to choose what floor wants to see, and I am not able to explain what is the reason why he cannot use that option.

    We (the MSP) are sometimes stuck by the system so we don't have enough resources to explain exactly what is happening and how to solve some problems.

    Hope this will solve soon and never more have this problem again.

    Thanks

    Hope

    0
    Comment actions Permalink
  • I can certainly understand your frustration with how the system works in this regard. it was designed to be as automated as possible and, therefore, some manual controls are not possible at this time.

    I wasn't able to find the Space you processed without that scan position. Keep in mind that hiding the position in Workshop will not fix the problem. Only if you delete the scan in Capture and re-upload the model data so that it processes without the scan position all together. It may leave a bit of a hole in your mesh in that part of the room.

    Anyhow, I'm sorry for the inconvenience and certainly hope some manual functionality will be implemented soon.

    - Amir

    0
    Comment actions Permalink
  • did you figure anything out? I just noticed on capture app you can change the floor a scan is on. It is on edit where the delete scan button is at.

    0
    Comment actions Permalink
  • That's true, you can move a scan or any number of scans between floors in Capture, but that won't change the final result. In this case, the best solution is to either delete the scan position from Capture or move everything out of that corner of the room and rescan. It's very strange, but I feel the problem has to do with the software not recognizing that corner as the same continuous floor on that level. That's probably confusing it and causing it to be part of the wrong floor.

    0
    Comment actions Permalink
  • Hello justincolbyvaughn,

    I figured out that issue and I moved that scan to the right floor but nothing changed in the final result, so I don't understand what is that option for. You can move your scans between floors but the final result is always the same. Strange...

    Hello Matterport-Amir,

    what I cannot understand yet is why the system decides which scan corresponds to each floor. If that specific position is not recognized in the third floor, neither in the second, so it's very confusing to me what is happening in this case. I cannot go and scan that model again so I have to hide the floor selection in showcase whit the f=0 function, but that is a terrible solution.

    Again, I think that corresponds to us decide which scan is in the right or wrong position.

    Thanks

    0
    Comment actions Permalink
  • I agree and maybe when creating a fully automated system some functions were inadvertently made less intuitive. The problem is that floors are not a natural concept to the technology. The technology was designed to make a 3D model based on a real world site. Even though you can set new floors in Capture, it's not actually creating a new floor, but instead simply removes the minimap image of existing scan positions. The underlying alignment data only knows one scan position was aligned with another.

    Therefore, whether you have a 3 story house all on a single floor in Capture or split up into 5 floors, it wouldn't matter. The processing engine first aligns all the data to build a mesh similar to what you see when viewing all floors. Once everything is aligned, it looks at predefined rules that only then determine which scan position should be associated with which floor.

    You're absolutely right, though, and there should be a way to override that so you can manually associate scan positions with different floors in some way or another. I don't know what the best way would be, whether via Workshop or Capture, but it certainly would be a great tool.

    0
    Comment actions Permalink
  • Thank you Matterport-Amir,

    We'll wait new manually functions soon.

    0
    Comment actions Permalink
  • I have the same problem https://my.matterport.com/show/?m=TrJMDwW4TZu

    i scanned 5 floors but after proccess its 8!!

    Matterport Support: Apr 10, 10:28 AM PDT Hello Dmitry, Thanks for following up with us. I've had our engineering team take a look and unfortunately this isn't something we can manually fix. There could be a few reasons why this is happening, most likely the height of these stairs between floors is not the common height our algorithm uses.

    0
    Comment actions Permalink
  • In regards to scan points appearing on the wrong floor in Workshop; the times I've had it occur is due to scan points in sunny/hot areas. And while it shows incorrectly in Workshop, the 3D Showcase is fine. But it is a bit frustrating when it happens.

    0
    Comment actions Permalink
  • Hi @dapalant,

    I checked out your Space and it is certainly strange the processing engine would break up the floors that way. Normally what happens in a 3+ story building is two floors may compress into one, which can usually be fixed. compression is caused by staircases not being as well scanned as possible. As the processing engine is aligning, it may confuse a staircase scan as being aligned to the staircase below and then everything drops down one floor.

    In your case, it's almost as though you did too good a job scanning the stairs :) I also spoke to the dev team about it and because the system automatically creates floors and in this case manually moving positions up and down will only misalign a currently well aligned Space, there really is nothing we can do here.

    I'm very sorry for the inconvenience.

    - Amir

    0
    Comment actions Permalink

Please sign in to leave a comment.