Beta: Capture 2.4 Details

Starting a thread in which anyone participating in the Beta for Capture 2.4 can share questions, tips, wishes and feedback.  
 
TL; DR:
  • This is not the final release. Some features below will be included in updates in the coming weeks.
  • You need to install the Test Flight app from the iOS App Store - the Beta builds are distributed through this app. Think of it as a parallel app store. 
  • If you want be a Beta adopter, send the email address that you use for iTunes or iOS App store to capture-beta@matterport.com.  
More details:
 
New features in the first 2.4 build (outlined in this week's newsletter)
  • Visual (Assisted) Alignment for empty and repetitive spaces. Visit  matterport.com/assisted-alignment to learn more.
  • Sorting: make it easier to find a scan job on your iPad.

  • Firmware Notifications: Improve awareness of new camera firmware builds. In multi-camera scenarios, make it clear which cameras are up to date and which are not.

  • Low storage warnings: Improve low storage warnings so that you have more time to free up space.

Coming soon in updates via Test Flight (in the coming weeks):

  • French, German and Spanish localization: if you operate your iPad in one of these languages, Capture will switch to present localized content within the app.

  • Enhanced organizational support: help you more easily manage multiple account relationships, minimize uploading to the wrong customer account.

How to get started:
  1. If you have signed up for the Beta, you will receive an email invitation to participate in a TestFlight beta. This is the mechanism with the iOS app store that supports Beta programs.
  2. Follow the link within the email to download and install the TestFlight application from the app store on your iPad. If you already have TestFlight installed you will see a new notification.  Within TestFlight you can also redeem the code sent in the email.
  3. Within the TestFlight application you will see a new version of the Capture app. After selecting install/update your Capture app will be updated to the latest Beta build of version 2.4.
  4. We will distribute additional updates via TestFlight and you will automatically be notified of an update. Note that this will be via Test Flight, not the usual iOS App store.
  5. When the final build of this version is released we will send you a note and you can install that from the iOS App store and be 'out' of the beta track.

Note: when installing a Beta app from TestFlight you may see a message that sounds scary - that you may lose all your data. This is a generic TestFlight message and installing the Capture 2.4 Beta will not erase your data.

0

Comments

22 comments
  • When scanning yesterday I attempted to delete a scan point or two in the model and they 'fade' but do not delete.  (attached an image showing what I see after delete attempt) You are able to press delete and it seems as though it is doing as requested but the point still shows and so does the data.

    Capture App v.2.4(590.18584)

  • @Lisa Hinson:  thank you. A couple of questions:

    - if you close out of of this job, and open it again, do you see the same ghosted images?

    - if you close Capture and re-open it, same thing?

    - what version of iOS are you on  (I can delete properly on iOS 10.3.3 as well as iOS 11 public beta), but just gathering data here.

  • When I close out of the capture app.  The scan points are back.  They are no longer ghosted.

    IOS v. 10.3.3 @Matterport-Kirk

  • Hi, I have encountered a problem on both my iPads. When using the scan app and you get the error that the camera is unstable then when you choose save it does not save the scan. Then you have to re scan.  Be

    scan 6 was unstable and disapered and then rescanned and save as scan 7.

     

  • Thanks @Lisa, I'm capturing this in a trouble ticket for our team to try to reproduce. If anyone else sees this issue, please chime in.

  • Could you please share the version of firmware that your camera is running, @jc3Dcx?  

  • Im on IOS 10.3.3 , iPad Pro and iPad Air II. Beta scan app

  • @Lisa Hinson: one of our engineers has reproduced your issue, and it appears to be somehow centered around deleting multiple scans.  You can get around it by just tapping a scan from while in the floorplan view and not in the edit scan view and just selecting delete.  Doing it 1 at a time that way will delete scans.  

    We'll let everyone know when this fix is included in a future update (which will come from Test Flight notifications, FYI, not the iOS app store).

  • Camera fiirmware 1.1.526.16604 pro 1

     

  • When I first discovered this could be an issue I had only tried to delete scan number one

  • @Matterport-Kirk Update to post.  With the new update there are two ways to delete a scan point.  

    1.  While using capture app - choose EDIT SCANS and delete - - This is what I was doing and what was not working.

    2.  Other option - press scan point and choose DELETE SCAN.  I just did this and the delete option works!!

    See if you all have the same results.  thanks

  • @Lisa,

    We now support the more streamlined taping on a marker in order to perform single scan options which doesn't.  That option doesn't seem affected by this issue.

    Option 1 that you highlighted seems to have an issue when you select multiple scans using the "Edit Scans" option it sometimes will not delete the scans.

  • @jc3Dcx, Thank you for your feedback.  We have been able to track down the cause for this issue and it seems to be an issue with the buttons mismatching in some of the error messages. Hopefully this fix will be in the next release to TestFlight.  

    In the meantime if you encounter this and want to save the scan, hitting "Delete Scan" with the version you have should actually keep the scan (The buttons are backwards).

  • Thanks, will try that, :-). Will also experiment more with the AprilTags. Thanks for the new features in the scan app, 

     

  • Hi @Matterport-Kirk  When I try to update the camera firmware by tapping the update green checkmark - nothing happens.

     

    iPadArir2- ios 10.3.3

  • @William Robinson I have 2 cameras and 2 Ipads and can only update my Pro1 firmware with one of my iPads (not the Ipad pro but the older ipad) -- weird .. but at least the other Ipad does work.  Do you have another that you can try also?

  • UPDATE - New version of Capture 2.4 (590.18642) is available via Test Flight.  

    You should have received an update notification that a new build is available.

    Updates:
    • French, German and Spanish localizations.
    • Fixed 'delete multiple scans at once' bug.
    • Improved Assisted Alignment (AprilTags) - the size of the printed target has been optimized to match this release. Please download and use updated targets at https://support.matterport.com/hc/en-us/articles/115007423487-Visual-Alignment#download
    • We have included Total Station markers on these targets for laser distometer measurements, which are more common in Architecture, Engineering and Construction (AEC) environments.
    • Improved stability and other minor bug fixes.

    Known issues (not yet fixed):
    • Very old iPads: do not use on a 32-bit device (original iPad, original mini, 3rd/4th gen iPads). We're working on fixing a crash on these devices.
    • Some rough edges around localization in a few places (truncation or translation glitches)

  • UPDATE: New version of Capture 2.4 (590.18659) released in Test Flight:

    What's new:
    • Performance improvements on iPads with 2GB and 1GB of RAM
    • Improved localizations in French, German and Spanish
    • Fixes some crashes and other bugs

    Known issues (not yet fixed):
    • Very old iPads: do not use on a 32-bit device (original iPad, original mini, 3rd/4th gen iPads).

  • I have a problem which says " capture has repaired one of your jobs " we started to scan new model it happened at 59th scan and before that we uploaded a model with 119scans. We tried to scan in that model it gave this error for the first time ..do you guys have a solution for this?

     

    https://i.hizliresim.com/a1QnA7.jpg

  • @Burak Ozyol 

    That shouldn't be causing you any issues, the app detected an issue with one of your scans and has corrected it automatically so just dismiss the box and continue as normal.




  • The problem is it doesn't let me continue it gives same error every time even we opened New model and tried to scan after a while it started to say it

  • AH Ok you didn't say it wouldn't clear.

    Not had that issue, have you tried closing all the running apps down and rebooting your iPad?

    Another question  is there still storage space on your iPad or is space becoming an issue?

Please sign in to leave a comment.

Didn't find what you were looking for?

New post