Problem with WebVR?

I used to be able to view Matterport Space in WebVR without the need to download any app. Was able to open the VR link directly from the matterport Space in the google browser.

Today, it no longer works?

When the VR link is clicked, there is 2 option.

1) google cardboard
2) samsung gear vr

Any option I click now will direct me to the same page prompting me to insert my phone in a Gear VR device (need to install Oculus apps)

Please advise. Thank you.

0

Comments

12 comments
  • Hello Jack,

    Thanks for raising this issue! It does appear a setting was inadvertently changed during a recent update which caused this issue. It has since been resolved and should be operating normally. If you are still having issues please check again after a few hours as it may take some time for the update to work its way though all of our servers.

    regards,

    Bob

  • Issue resolved. Thank you Bob.

  • Hi Bob,

    The WebVR is not working again. 

  • Hello Jack,

    Just checked this by visiting the reef penthouse in the gallery on matterport.com using a pixel phone, (android 7.1.2 and chrome 60), and webVR appears to be functioning normally. If you are continuing to have difficulties please provide the specifics similar to what i have detailed.

    Regards,

    Bob

  • Hi Bob,

    I am using Samsung Galaxy S8+, Android version 7.0, Chrome 59.0.3071.125.

    When I clicked "Enter VR", the page just refreshed and could not enter into WebVR. 



  • Hello Jack,

    Thanks for the additional information! I tracked down an S8+ here, (running the same versions of Android and Chrome), and was able to launch a model from the gallery using WebVR without issue. Evidently there was an issue with WebVR and chrome, (not specific to Matterport), on the S8+ but the story is that it was fixed with release 59. I suggest attempted to view another WebVR page outside of Matterport, one example you can use is https://threejs.org/examples/#webvr_cubes . If you find that page fails to load i would next confirm the WebVR is enabled in the browser settings at chrome://flags.

    Regards,

    Bob

  • Hi Bob,

    I tried, and still not working. 

    It is weird that it was working fine just 2 days ago. 

     

  • Helo Jack,

    I am curious if you were able to launch the example webvr site i recommended in my last comment. I would also suggest updating to Chrome version 60 to see if that has an effect. Lastly a few potentially silly tips, first make sure you have a good WiFi connection, secondly, be careful not to touch the screen as this will cause the phone to exit VR mode.

    Regards,

    Bob

  • Hi Bob,

    I tried and unable to launch the example webvr site either. Yes, already updated to version 60. Yes, good wifi. The only button I touch is "Enter VR". Still, unable to enter VR mode.

  • Please see this video here - https://www.dropbox.com/s/32mh9xo9hddq3lm/VID-20170826-WA0000_1.mp4?dl=0 

    I demonstrate the issue for your better understanding. 

  • Hello Jack,

    Thanks for the additional information! The fact that it is occurring on the example website as well pretty much confirms that the issue is with the device and not with the implementation of WebVR at Matterport. I would suggest reaching out to Samsung directly. Since you did have it working at one point it may be worth trying to think about any settings or file versions which changed between the time it functioned and when it stopped working. One area to think about would be screen resolution. If you find i fix it would be great if you could post it here!

    Regards,

    Bob

  • Hi Bob,

    I spent one whole day uninstalling, reinstalling Chrome and every related apps, searching around for solutions.. And finally, I think the issue lies with the settings in Display. Screen Resolution must be set at the highest resolution (WQHD+ 2960x1440) and I think the Screen Zoom setting must be at Small. Then, finally, the WebVR works. 

    Checked my email and saw your message... arh... you mentioned about screen resolution too. I should have checked my email first. So much time wasted. 

    Anyway, glad that it finally works. Thank you so much for your help. 

Please sign in to leave a comment.

Didn't find what you were looking for?

New post